[ How-to ] BTD-400 Windows Driver Installation

Note: This article applies only to Windows 10. Windows 11 installation is plug and play - no extra steps needed.

Windows 10 may report that the driver is not available for the BTD-400.  In that case, installing drivers is necessary in order to use the BTD-400.

Let’s first check the status of the drivers:

  1. Hold down the WIN key, then press the R (Win+R) key.  Type “Control” then hit enter.


  2. Select Hardware and Sound


  3. Select Device Manager


  4. The Bluetooth driver should be located under Other Devices


  5. Right-click BCM20702A0 and select “Properties”.  You should see the following error.  This confirms that you have the Windows 10 October 2020 update.


Installing the Missing Drivers

You may be able to install the drivers via Windows Update.  Hold down the WIN (Windows Logo) key, then press the S key.  Type in update and select Check for Updates

Click on Check for Updates..

Click on View all optional updates.

Expand Driver updates.

Scroll down and select Broadcom Corporation, then click on Download and install.  It should take no more than 5 minutes to complete the installation.

Check the Device manager to confirm that the drivers installed.  The device should be ready for pairing.  


Note:  Please contact us by phone or chat if you require more assistance.  We are able help you more thoroughly by doing a remote session.

Manual Installation

If you still aren’t able to load the driver from Windows Update, use the link below to install the driver manually:
WIDCOMM Bluetooth Software

1 Like

Kudos to the person(s) responsible for writing the instructions for troubleshooting missing driver/update. I am 75 years old and what a pleasant experience I had following your so-easy-to-follow instructions and getting Bluetooth back.
I am a happy “camper” once again.

Tommy Sekelsky

Hi, Tom! Welcome to the forums, and thank you for the feedback. He put a lot of work into it, and he’ll be glad to hear it’s been helpful.

That driver does not show up under windows update for me. Why doesn’t Kinivo provide the driver as a download on the support page anywhere?

Well that still doesn’t work following subsequent WIN 10 updates…waste of money.

Have you found a solution yet I am having the same issue with the windows update option not working…

Same issue with installing BTD400 Bluetooth device on a windows 10 PC.

BTD-400 out of the package, Windows 10 doesn’t find it, followed the above instructions and it’s working.
Bought this to replace old Kensington 33348, which couldn’t find my xbox controller. BTD-400 found it straight away.

Wow, this is still a live issue in 2022. What in the world are they doing over there at Redmond? The workaround in the OP worked for me.

I am trying to install the BTD-400 driver with Windows 10. I follow all your instructions. Computer recognizes device, but when I go to Optional Updates, Broadcom Corporation is not listed. Any suggestions?
Thank you,

Hi Sandy - were you able to resolve the issue? We tested again - Broadcom driver is showing under Optional updates > Drivers

It says this device is compatible with Mac OS but my laptop doesn’t seem to recognize it at all. I don’t know where I can even begin to look. Any guidance with Mac OS installation?

Hi, Valera!
Welcome to the forums.

If the adapter isn’t visible when you first plug it in, there are two things you can do:

First, unplug the BTD, toggle Bluetooth off for six seconds, plug in the BTD, wait six seconds, then toggle Bluetooth on. MacOS can be a little fussy about Bluetooth dongles, and may just need time to sort itself out at each stage.

If that doesn’t work, the following command should force MacOS to switch adapters:

sudo nvram bluetoothHostControllerSwitchBehavior=always

To switch back to the internal adapter:

sudo nvram -d bluetoothHostControllerSwitchBehavior

If neither of those works, please let us know the model you’re using.

WIndows 11 couldn’t find it so I just installed the WIDCOMM Bluetooth software from the other link because this one on this page doesn’t work. Windows 11 sees it now… had to manually install.

I’m sorry about the broken link. It should be working now. Thank you for letting us know.