Problems with BTH220 and BTH240

I love my Kinivo headphones, but about a year ago, both pairs started acting strangely. When I connected to my Galaxy S21, they would only connect for “Phone”, not “Music”. Eventually, if I manually turn things off and on again, they will fully connect.

After they fully connect, the sound still won’t work immediately. I’ll start playing an audiobook, and the book will go forward, ticking off the seconds, but the actual audio doesn’t kick in until I skip backward and forward several times. Sometimes it will start and then stop a few times. Once the problem is resolved, it works great for hours. Again, I thought it might be a problem with the app, but it occurs in three different audiobook apps.

It sounds similar to this, only it happens with both headsets:

This happens with both my BTH220 and BTH240, so I thought it must be a problem with the phone, but I just replaced it with an S23, and the same thing occurs. Was there some update to Galaxy phones that broke compatibility with your headsets? Do you know if there’s a setting I can change to resolve this issue? I doubt either headset is still under warranty, but I’m hoping there is a support person or member of your community who can point me in the right direction. Thanks!

I had to enable developer option in Android and then go into and try different Bluetooth avrcp versions. And if I remember right I think I turned off a2dp hardware offload.

After turning on the hardware offload switch (which means turning off hardware offload :roll_eyes:), and switching AVRCP to 1.6 (1.4 had no effect), the headphones seem to connect better. Though it takes a bit to connect to music (~15 seconds?), it does connect so far. I still get the audio glitches, though. I’ll try 1.3 next.


I tried several settings, but none have been reliable. I finally just bought the SoundBot SB221, and they have no trouble connecting. Some change in the OS must not work well with Kinivo’s firmware. It’s a shame, but I got several years of good use out of them.